Guide :: Install El Capitan Mac OSX on Hackintosh PC [ Vanilla Installation Method ]

Posted on Updated on

Guide :: Install El Capitan Mac OSX on Hackintosh PC [ Vanilla Installation Method ]

Guide moved to new site:

http://osxarena.com/2015/06/install-10-11-mac-osx-on-hackintosh-pc-vanilla-installation-method-golden-master/

Advertisements

56 thoughts on “Guide :: Install El Capitan Mac OSX on Hackintosh PC [ Vanilla Installation Method ]

    Kyler Phillips said:
    June 15, 2015 at 7:41 pm

    Excellent post and a great write up (best one I’ve found so far) wish I had saw this before installing Yosemite on Clover – Is there currently a way to upgrade to OS X El Capitan directly from OS X Yosemite? Thanks

    Liked by 1 person

    insanelydeepak responded:
    June 15, 2015 at 8:01 pm

    Yes , make USB from First Method and install directly will upgrade nothing will lost ..but not sure about second method Good Luck

    Like

    Kyler Phillips said:
    June 15, 2015 at 11:45 pm

    Thanks insanelydeepak, just a quick question which folder does the FakeSMC.kext need to go in? I’ve saw some where a 10.11 folder is created and others where it is put in the Other folder.

    Liked by 1 person

    Kyler Phillips said:
    June 16, 2015 at 3:05 am

    @insanelydeepak I’ve followed your guide as per method 1, on initial boot I used the following boot flags (kext-dev-mode=1 -v rootless=0) I was unable to get in to the installer, it went to a grey screen with spinning beach ball logo and then the apple logo appeared with a loading bar and got about 3/4 of the way and did nothing after? I put FakeSMC.kext and NullCpuPowerManagement.Kext in EFI/CLOVER/kexts/Other and removed VBoxHfs-64.efi and added HFSPlus.efi in /EFI/CLOVER/drivers64UEFI/. Am I missing anything, I’m still able to boot in to Yosemite safely at the moment as the OS X 10.11 did not fully boot.

    See picture below:
    https://onedrive.live.com/?cid=61e2ab563f3ca50c&id=61E2AB563F3CA50C%2122779&v=3&ithint=photo,JPG&authkey=!AH_tlEtAjNAnJHY

    Thanks for all of your help

    Like

    insanelydeepak responded:
    June 16, 2015 at 5:57 am

    it requires to be in 10.11 folder

    Like

    insanelydeepak responded:
    June 16, 2015 at 5:58 am

    Boot with -v and then post pic where you getting stuck

    Like

    Kyler Phillips said:
    June 16, 2015 at 2:26 pm

    Do I still need to use kext-dev-mode=1 for loading unsigned kexts to boot or should -v work on it’s own?

    Like

    insanelydeepak responded:
    June 16, 2015 at 8:22 pm

    kext-dev-mode=1 and rootless=0 is required to load unsigned kexts

    Like

    calbbru said:
    June 17, 2015 at 2:18 pm

    I installed the system using the first method and everything is working fine except one thing: I can’t install .pkg applications, at the end it says: Installation Failed.
    What’s the problem?

    Like

    insanelydeepak responded:
    June 17, 2015 at 6:56 pm

    which application …Clover Bootloader ???

    Like

    lucy said:
    June 17, 2015 at 9:06 pm

    MBR Patch?

    Like

    insanelydeepak responded:
    June 17, 2015 at 10:09 pm

    No MBR Patch now , will add asap will available

    Like

    calbbru said:
    June 18, 2015 at 3:24 pm

    Yes, but not just that but any .pkg I try to install

    Like

    insanelydeepak responded:
    June 18, 2015 at 7:36 pm

    why so ??? could you provide me log ??? try this pkg http://sourceforge.net/projects/cloverefiboot/

    Like

    calbbru said:
    June 18, 2015 at 8:17 pm

    I tried it but i got the same error. To successfully install clover i had to install another os x system in another partition and change the location

    Like

    insanelydeepak responded:
    June 18, 2015 at 8:27 pm

    still you cant install clover to usb ????

    better way use 2 USB make a USB for Clover using BootDiskUtility on windows

    Like

    calbbru said:
    June 18, 2015 at 8:44 pm

    No, I think you misunderstood.. The problem is not with the USB drive but in the post-installation. I successfully installed el capitan but I can’t install any pkg in the system. For clover, I found a solution with another partition but the problem is still there for other apps

    Like

    jeff said:
    June 18, 2015 at 11:35 pm

    Does clover + 10.11 solve any of the iMessage HDMI audio problems or create new ones? I have finally gotten my 4K working with audio with the Multicast method and are wondering if life is simpler with clover and 10.11

    Like

    insanelydeepak responded:
    June 19, 2015 at 4:04 am

    hope so , my iMessage and HDMI only working with Clover at any OSX Version

    Like

    insanelydeepak responded:
    June 19, 2015 at 4:06 am

    provide me installation log so i can look into matter , good luck

    Like

    insanelydeepak responded:
    June 19, 2015 at 4:08 am

    Now its Available MBR Patch for El Capitan

    Like

    DoIReallyNeedaUsernameWellIguessIdo said:
    June 22, 2015 at 10:22 pm

    Could you please post the latest revision of the Chameleon Bootloader as a .pkg? I got Clover to work, but get a kernel panic and immediate restart after loading the installation partition. Can´t resolve this error – but Chameleon always worked for me – since 10.6 :-). I can´t find the pkg anywhere, so it would be very kind of you to upload it somewhere!

    Like

    insanelydeepak responded:
    June 26, 2015 at 10:26 pm

    Latest Chameleon Found Here Chamelelon Bootloader
    whats error ?? report will try to solve it //

    Like

    João Felipe Alves said:
    July 16, 2015 at 11:13 am

    I duplicated my Yosemite via Time Machine Backup in another drive and installed El Capitan. It works, but i’m having a problem with Wireless Network Adapter(RTL8192CU).
    It closes instantanealy when i open it.
    Anybody had the same problem?

    ps.: I also made a clean install of El Capitan and the Wireless Network Adapter didn’t worked as well.

    Sorry for the bad English, it’s not my native language.

    Liked by 1 person

    João Felipe Alves said:
    July 16, 2015 at 11:15 am

    ps.: it’s an encore enuwi-2xn45

    Like

    insanelydeepak responded:
    July 19, 2015 at 7:07 pm

    it’s sounds incompatibily issue with driver you are using for RTL8192CU , where did you get this from Vendor site , have look for updated version if any available

    Like

    insanelydeepak responded:
    July 19, 2015 at 7:08 pm

    i checked realtek site no updates found till now but you can you do kexts and DSDT patching will make this working proper ..

    Good Luck 🙂

    Like

    RAJESH PAL said:
    July 23, 2015 at 1:20 am

    hi deepak,
    this is rajesh, i followed ur 2nd installation guide for chameleon, i stucked at last stage, im unable to extract kernel using pacifist, can u please provide me kernel file so that i can install it on my hp g6.

    Like

    Polo Hernandez said:
    July 29, 2015 at 12:58 am

    where exactly i have to copy the kernel extracted

    Like

    insanelydeepak responded:
    July 29, 2015 at 8:09 pm

    In root directory of usb for e.g where base system.dmg ,system , library etc folders are exist ..

    Like

    insanelydeepak responded:
    July 29, 2015 at 8:10 pm

    Sorry for late reply i was out of town , now available to help plz let me know if you need anything ,
    Regards
    Deepak

    Like

    Polo Hernandez said:
    July 29, 2015 at 9:27 pm

    do i add including the kernels folder or only the kernel file

    Like

    insanelydeepak responded:
    July 29, 2015 at 9:31 pm

    Just use kernel if still bootloader will show can’t find kernel than add folder or you can also use bootloader to tell bootloader where kernel is exist

    Like

    Rohan Sharma said:
    August 23, 2015 at 4:34 pm

    Hello Sir Deepak, I am trying to install Yosemite 10.10.5 on my AMD PC, so I used a custom kext and I also applied the MBR patch. I successfully reached to the installation screen but the installation was unsuccessful and I was unable to install yosemite. Kindly give me some suggestion to resolve the issue. The Installation Log is here : https://goo.gl/AXuEFO

    Like

    Greg said:
    August 31, 2015 at 12:05 am

    Hi

    not sure if i need an ssdt or dsdt. I added kexts in the 10.10/ kexts folder. clover configurator is downloaded but i guess i can’t use it on this mac pro 5,1. osx 10.9.4. I’m lost

    Like

    insanelydeepak responded:
    September 1, 2015 at 6:21 am

    what you need ??
    SSDT or DSDT place in Acpi/Patched folder 10.10 folder will contains kexts which are neccessary like FakeSMC and NullCPU rest is your choice

    Please clear your issue with system specs

    GoodLuck

    Like

    insanelydeepak responded:
    September 1, 2015 at 6:32 am

    Hello mr rohan
    Have you used custom kernel for it ???

    Like

    Ivan said:
    September 9, 2015 at 9:23 pm

    I am having an issue with my touchpad not scrolling. I am on a Alienware 17 2014 model.

    Like

    therion23 said:
    September 17, 2015 at 4:31 pm

    The same happens to me when the wifi dongle is not inserted or the kext is not properly loaded. Try see in System Information if the kext is there and loaded – If it is, you could try the software (not the driver) for the ZyXEL NWD2205 because frankly it’s the same kext they are “talking to”.

    Like

    insanelydeepak responded:
    September 17, 2015 at 4:35 pm

    El-cap changes too much you need to disable SIP to get all kexts working

    Like

    therion23 said:
    September 17, 2015 at 8:18 pm

    How would one go about disabling SIP on an installation media? My installation shenanigans (with the GM) stopped at the exact same problem that FakeSMC would not load. Any ideas? Or is it a “wait and see what the Clover guys come up with” thing?

    Like

    insanelydeepak responded:
    September 17, 2015 at 9:05 pm

    For Clover :
    RtVariables

    CsrActiveConfig
    0x67
    BooterConfig
    0x28

    Change csr value to 0x03 , 0x00 or what type of security you want
    type in terminal : csrutil status

    show display you status

    make sure your all kexts loaded properly Type in Terminal : kextstat
    will dispaly you kext is loaded or not

    Good Luck 🙂

    Like

    therion23 said:
    September 17, 2015 at 10:52 pm

    You, Sir, are a hero! Had the installer ready already, just got a beach ball instead of a DSMOS arrival. Perfect install first time with no flaws or scary delays, network and sound fixed (so yes, the RTL8192CU driver from ZyXEL does work on El Capitan, as you can see).

    Note that this trick ONLY works with Clover 3259 and above, and a CsrActiveConfig value of 0x03 allows unsigned kext’s but keeps the other security – you might want that.

    Thank you so much deepak!

    Like

    insanelydeepak responded:
    September 18, 2015 at 6:02 am

    SIP depends upon you what you want choose which suites you best
    If you still have issue and check kext is loaded or not , make them to properly load by os kernal

    Enjoy Hack
    Best Regards

    Like

    Jorge Rodriguez said:
    September 20, 2015 at 6:29 am

    I installed el capitan GM candidate in a ga-p55m-ud2 mobo and I can’t get any USB ports to work. Thus, my USB mouse and keyboard cannot work. I tried the USB port restriction with no luck.

    Like

    Jorge Rodriguez said:
    September 20, 2015 at 6:30 am

    I’m looking for a solution to this issue

    Like

    insanelydeepak responded:
    September 20, 2015 at 6:32 am

    What issue you are having, port issue or usb not working ??

    Like

    insanelydeepak responded:
    September 20, 2015 at 6:32 am

    Answer me please

    Like

    Jorge Rodriguez said:
    September 20, 2015 at 6:35 am

    When El Capitan starts up and upload the desktop both the USB keyboard and mouse are not working

    Like

    Jorge Rodriguez said:
    September 20, 2015 at 6:40 am

    I believe that the issue is related to the USB ports but I’m not 100% sure. In the Yosemite partition everything is working fine

    Like

    Jorge Rodriguez said:
    September 20, 2015 at 6:41 am

    tried the USB port restriction fix with no lu

    Like

    insanelydeepak responded:
    September 20, 2015 at 6:42 am

    USB port allows you woking count of ports as it available on original Mac ..
    Which bootloader ??
    Smbios ??
    What kexts you used ??

    Like

    Jorge Rodriguez said:
    September 20, 2015 at 6:58 am

    I’m using clover 3270 and fakesmc, 3rdpartyesata, Realtek8xxx, and genericrehabman USB 3.0 kexts

    Like

    Jorge Rodriguez said:
    September 20, 2015 at 6:59 am

    and voodoops2 kext

    Like

    Jorge Rodriguez said:
    September 20, 2015 at 5:23 pm

    Ordinarily I use IMac 11,3 because it is the best approximation to my pc profile. But to fix this issue I have tried other SMBIOS such as IMac 14,1, iMac 12.1 or Macpro 6.1 in connection with the fixes that some people have published in other sites such as hackintoshzone

    Like

    Jorge Rodriguez said:
    September 20, 2015 at 6:40 pm

    I created a separate partition cloning my Yosemite install and did a direct update to El Capitan GM candidate booting through Clover Legacy BIOS install using a DSDT). The problem is that when it boots the USB mouse and keyboard are not working and I believe that none of the USB ports are working. I tried various USB fixes such as dummy kexts and changing the SMBIOS that I use normally (IMac 11,3) to others (Macpro 6.1, IMac 12.x, IMac 14.1) and no success. The only fix that I haven’t tried is Rehabman since I believe it is oriented to UEFI capable mobos. The kexts that I upload in Clover kext folder are fakesmc, Ethernet kext, voodoops2, 3rdpartyesata and generic Rehabman USB 3.0 kext since I have a PCIe USB 3.0 expansion card. Could anyone help me to sort this out?

    Like

Comments are closed.